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What Is a Macro? What Is VBA?

A “"macro-instruction” = Visual Basic for Applications

= A sequence of instructions * Programming language used by macros

= Designed to automate a process

= Used by all Office applications

. . Word
—Can-perform-time=consuming-procedures Excel
automatically =
PowerPoint
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What Can a Macro Do? What Can VBA Do?

= Insert boilerplate text Everything Macros can do, plus:

= Jump to another location/worksheet = Automate complex procedures

= Automate repetitive operations

E.g., Same procedure has to be done in 10 different
workbooks

= Create custom functions
Create-custom—commands

= Create a simple “front-end” for fool-proof data
entry

How to Create a Macro

Developer Tab

Two ways: = Used to create and edit macros

= Record it

= Normally hidden from users
With the Developer Tab

= Write it in the VB Editor p——

Insert  Pagelayout  Formulas  Data

& & B e
" ode Elfuno

TeNCes | Add- Excel COM
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Developer Tab

VB Editor

= Not normally visible Tool for editing macros

= To view it:
Right-click any tab (e.g., Home)
Choose: Customize the Ribbon...
On-right,—check:-Developer
Click OK

Can also run macros
Can help “debug” a macro

To-view-the VVB-Editor:
Click: Developer > Visual Basic
Or: Alt + F11

Where to Store a Macro

How to Run a Macro

Two Places: Six possible ways:

= Current workbook
Macro works only when this workbook is open

= Select a shortcut key combination

= Run the macro from the VB Editor
= Personal Macro Workbook
Hidden workbook, opens automatically
Macros will work with all your workbooks
But, will not “travel” with workbooks

= Assign the macro to:
A shape
A button
The Quick Access Toolbar
One of the ribbon tabs
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Create a Macro Run the Macro

A Macro to Insert My Name = Press: Ctrl + Shift + N

Click: Developer > Record Macro
= Problem:

Set Macro name: InsertMyName .
Macro always puts company name in the same cell

Set Shortcut key: N [Shift + N]
Click:—OK

Enter your name

Enter your company below it
Click: Stop Recording

“Use Relative References” ? Create a Macro

A Macro to Insert My Name Anywhere

= Default setting: Off
I.e., Macro will use Absolute References

It will work on the cell selected when the macro was
created

Click: Developer > Record Macro

Set Macro name: InsertMyNameAnywhere
Set Shortcut key: A [Shift + A]

Click: OK

Click: Use Relative References

= Click to turn on

Now macro will work on any cell
Type your name

Press: Ctrl + Enter
Click: Stop Recording
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How to Edit a Macro

Two Choices:

= Easy Way: Remove and re-record it

= Hard Way: Edit the VBA code

THE VISUAL BASIC EDITOR

The VB Editor

= For editing macros and procedures

Code for a Simple Macro

4 Bookl - Modulel (Code)

4 Microsoft Visual Basic for Applications - Book1 |EGE"Ef8|l L] ]lnseﬂMyName

le Edit View Insert Format Debug Run Tools Add-ns Window Help Sub InsertMylName ()
@ 4 b0 KEFY @ i1, colt

InscrtMyName Macro

¥4 Book1 - Module (Code)

ActiveCell.FormulaRI1Cl "Rich Malloy™
Rangs ("C3") .Select
BctiveCell.FormulaR1Cl = "NCC"
Range ("C4") .Select

End Sub
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# Book1 - Modulel (§ode)

21

[E={E
(General) v j IlnsenMyNamE j

Sub TnsertMyName () =
) e rEHNaES MASED

ActiveCell.FormmlaR1Cl = "Rich Malloy™

Range ("C3") . Select

ActiveCell.FormulaR1Cl = "HCC"

Range ("C4") . Select
End Sub

Code for the Second Macro

ActiveCell.Fo

ActiveCell.Of

ActiveCell.Fo

ActiveCell.Of
End Sub

== |

A Relative Reference

Rich Malloy, Tech Help Today

Suk InsertMyNameAnywhere ()

rmulaR1C1l = "Rich Malloy™

£ ., 0) .Range("A1").Select
RIC1 = "HCC™

. 0) .Range ("Al1"™).S5elect

Move Down 1 Row

Code for the First Macro
[ % Book1 - Modulel (Code)

|(General]

L] ]InsenMyName

Sub InsertMyName ()

InsertMyName Macro

ActiveCell.FormulaR1Cl
Range ("C3"™) .5elect
ActiveCell.FormulaR1Cl "HCC™
Range ("C4") .Select

End Sub

"Rich Malloy™

Absolute References

Watch Code Being Created

= Open both Excel and VB Editor
Click: Developer > Visual Basic

Put them side by side

In Excel, record a macro

Watch code appear in VB Editor

6/23/2020



Excel Macros and VBA

Create a Macro Set Several Properties at Once

= Create a Macro to:
Set cell as Bold
Center text in cell

= The With Statement

Example:

With ActiveCell.Font
.Name = "Calibri"
.Size = 16
.Bold = True

End With

= Note the With statement

Beyond Macros

= Macros are useful

= But to really get things done, we need to use VBA

USER-DEFINED FUNCTIONS

Rich Malloy, Tech Help Today
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User-Defined Functions

Functions make formulas easier
Excel has over 300 functions
But you may need additional ones

You-can create-functions-with-VBA

Problems

= User-Defined Functions must be in current
workbook

= If in Personal Macro Workbook,
You must refer to PERSONAL workbook:

=PERSONAL .XLSB!pctgrowth(B11,C11)

If you send a spreadsheet to someone,
Functions will no longer work

Rich Malloy, Tech Help Today
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Example: Calculate Percent Growth

= VBA Code:

Function PctGrowth(old, newer)
" Calculates the percent growth

PctGrowth = (newer - old) / old

End Function

Visual Basic for Applications

VBA
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VBA Code

= Viewed in the VBA Editor
= Code is stored in a Module

*= Organized into Sub procedures and Functions

Hierarchy of Excel Objects
Application

Workbooks

Rich Malloy, Tech Help Today

How VBA Views a Workbook

= A Workbook is a set of Objects

= Examples:
Application
Workbooks ("Bookl.xlsx")
Worksheets("Sheetl™)
Range ("€3")
Cells (2,3)
Worksheets ("Sheet2") .Range ("D3")

How VBA Refers to Cells

Selection Or ActiveCell

Whichever cell is selected

Range ("C3")
Cell C3

Cells(254)
Cell D2

Worksheets ("Sheet2") .Range ("D3")
Cell D3 on Sheet2

6/23/2020
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VBA Objects Can Have: Objects Properties

Subclasses

= Value, Bold, Font Color, Borders
E.g., Worksheets is subclass of Workbooks

Examples:
Properties

= R "Cl") .Font.Bold = T
E.g., Value, Bold, Font.Color ange ) . Fon © tue
= Cells(3,3).Val = 16
Methods ellis(3,3) .Value

E.g., Save, Print, Copy, Paste = Selection.Font.Color = vbBlue

Events * Range (“D5") . (.Borders (xlEdgeBottom) .Weight =
E.g., On Open, On Close, On Click x1Thick

Visual Basic Constants Objects Also Have Methods

= Use instead of numerical values = Copy, Paste, Merge, etc.

= Easier to specify Properties Examples:

= Examples:

Bl = FF
vbBlue 0000 = Jorksheets("Sheet1")y.Paste
x1Thick =

= Range ("A1") .Copy

x1EdgeBottom = ? = Selection.Merge

Rich Malloy, Tech Help Today 10
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Object-Oriented Programming Warning
*= Old Style:
Tell the program to do something
Copy Range ("D3") = Always work on a copy

= Never work on a live workbook

* Object-Oriented Approach " VBA has no Undo button
Tell-the-object to-do-something
Range ("D3") .Copy

Your First VBA Program

= Open VB Editor

= In Project Explorer, select current workbook (e.g.,
“Book 1”)

= Click: Insert > Module

YOUR FIRST VBA PROGRAM

B veAProject (PERSONALXL

Rich Malloy, Tech Help Today 11
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Your First VBA Program

* In the Modulel Code Window, type:

& Book1 - ModuleT (Code) [re=e]E)
v| [myFirstProgram
Sub MyFirstProgram/()
' By Rich Mallowy
' June 24, 2020

MsgBox ("Hello, World!™)

End Sub

Congratulations!

= It works!
= Click: OK

= And have a beer

Microsoft Excel X

Hello, World!

Rich Malloy, Tech Help Today

Run the Code

Do one of the following:

= Click: Run > Run Sub/Userform
= Press F5 key

= Click the Run button

Format Debug Run Tools

343-. pom @ b

CREATE A REAL VBA PROGRAM

6/23/2020
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Beyond Macros: A VBA Program Can:

= Alter its actions depending on conditions
= Do things over and over again

= Can send you messages about its status

Scenario: Angry Boss

= Wants blank lines in table to
separate groups of data

= But you want no blank lines
Easier to sort & create Pivot Tables

Rich Malloy, Tech Help Today

VBA Programming Principles

= The Macro Recorder is your friend
Let the Recorder create code for you
Google is another good friend

» Practice Evolutionary Development
Start-simple-and-gradually-improve
Save & run at every step
Fix errors immediately

= Use comments and white space

Setup

= Download the file:

6/23/2020
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Create a VBA Macro

Goal:

A Macro that will insert blank rows above all cells in
Column A that are Bold. Another macro will do the reverse

Strategy:
= Start with a simple macro

= Gradually enhance it

First Step:

= Make a copy of the current sheet
= Never work on live data

= VBA has no Undo button

Rich Malloy, Tech Help Today
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What VBA Code Should We Use?

= We need to:
Insert a blank row
Move down 2 rows
Check if a cell is bold

= Solution:
Let’s see what the Macro Recorder does

Next: Create a Macro

Create a Macro to:

= Insert a Row above the current cell

= Move down 2 rows

=Set-a-cell-as-bold

14
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Then: Edit the Macro

= Edit the previous Macro to:

= Insert a row, only if the cell is Bold

If This, Then That

= The If Statement
“If This, then That, else Another, end”

Example in English:

If the selected cell is bold, Then
Insert a row above the cell
Move down two rows

Else
Move down one row

End

Rich Malloy, Tech Help Today

IF

= Excel has an IF function

= VBA has an IF statement

If This, Then That

Example in VBA Code:

If Selection.Font.Bold = True Then
Selection.EntireRow.Insert

ActiveCell.0ffset(2, 0).Select
=33

ActiveCell.Offset(1l, 0).Select
End If

6/23/2020
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Edit the Macro Again

Adjust the previous Macro to:
= Repeat the process

= Maybe 100 times

Loops: “Shampoo, Rinse, Repeat”

The Process in English:

Start with I = 1; End when I > 100:
If selected cell is bold Then
Insert row above cell
Move down two rows
Else
Move down one row
End If
Increment I

Rich Malloy, Tech Help Today

Loops: “Shampoo, Rinse, Repeat”

* Loops repeat a procedure many times
= Several ways to loop in VBA

= We will use the FOR loop
Simple to use
Repeats a set humber of times

The For Loop

The Process in VBA Code:

For I = 1 to 100
If Selection.Font.Bold = True
Selection.EntireRow.Insert

ActiveCell.0ffset(2, 0). Select
Else
ActiveCell.Offset(1l, 0). Select
End If
Next I

6/23/2020
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Add Comments & White Space

' Repeat 100 times
For I =1 to 100

' Check if cell is bold
If Selection.Font.Bold = True
' If bold, insert blank row above
Selection.EntireRow.Insert
‘ Then move down two rows
ActiveCell.0ffset(2, 0). Select
Else
' Otherwise, move down just 1 row
ActiveCell.Offset(1, 0). Select

End If

Next I ‘ Repeat the above

Edit the Macro

Edit the previous Macro to:
= Delete the current row ...
= ... if the first cell is blank

= FElse-move down-onerow

Rich Malloy, Tech Help Today

Create the 2nd Macro

Record a Macro to:
= Delete the current row

= Move down one row

Solution

If Selection = "" Then

Selection.EntireRow.Delete

Else

ActiveCell.Offset (1,0) .Select
End If

6/23/2020
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Edit the Macro Again

Edit the previous Macro to delete all blank rows:
1. Delete the current row ...

2. ... if the first cell is blank

3. Move down one row

4. Repeat maybe 100 times

Run the Macros from Buttons

Add two buttons to run the macros
Click: Developer > Insert
Use Form Controls

Active X-Controls-are more complex

Rich Malloy, Tech Help Today
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Solution

For i = 1 To 100
If Selection = "" Then
Selection.EntireRow.Delete
Else
ActiveCell.Offset (1, 0).Select
End If
Next i

Form Controls

Various tools on the Developer Tab:
= Buttons
Checkboxes

Slidebars

Text boxes

List boxes

Combo boxes

18
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Bugs Happen - The Debug Mode

ﬁ Microsoft Visual Basic for Applications - Book1 [break] |
Hle Edt: View 1nsertgebug Run  Tpef] Click: Reset

EE-d B9 » B SEY @ in3ncol

Project - VBAPraject x|

B 4 Book' - Madulel (Code)

&% Solver (SOLVERXLAM) |(General) r| [macros
=&} VBAProject (Book1)

-5 Microsoft Excel Objects
Sheet1 (Sheet1)

Quote

“There are two ways to write error-free programs;
only the third one works.”

— Alan J. Perlis

If Selection > 0 Then

ThisWorkbaok mE=A50

=15 Modules

Selection.Font.Bold = True
-~} Module1

Else
(-8 VBAProject (FUNCRESXLAM) Selection.Font.Bold = False
&3 VBAProject (PERSONALXLSB) End If

End Sub

Properties - Modulel x|
| Module1 Module -

Further Learning on YouTube:

= Leila Gharani:

» Learnit Training:

THE JOY OF CODE

= Excel\V/BAHelp:

Rich Malloy, Tech Help Today 19
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5 Reasons Why Programming Is Fun:

The sheer joy of making things

The pleasure of making things that are useful to other
people

The fascination of fashioning complex puzzle-like objects
of interlocking moving parts

The joy of always learning

The delight of working in a tractable medium

— Fred Brooks, 1975
The Mythical Man-Month

Rich Malloy, Tech Help Today

Rich Malloy
Tech Help Today
techhelptoday.com

HAVE FUN!
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