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[bookmark: _Hlk520288586]How to Use the Get & Transform Feature in Excel
By Rich Malloy, Tech Help Today (www.techhelptoday.com) 

The Get & Transform tools in Excel can save you quite a bit of time when you bring data from various sources into a spreadsheet. These tools, which were formerly called Power Query, are a little tricky to set up, but once you create them, you can use them over and over again.

In the following projects, we are going to use various Get & Transform tools to bring data in from a website, a stepped table, a multi-column table, and from all the spreadsheets in a particular folder.
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We’ll be using a set of data files packaged in a Zip folder. To get the set of data files, download the following zipped folder: Get-and-Transform-Data-Files.zip

[bookmark: _Toc520278729]Get Data from a Website
This technique is handy for capturing data from a website. It especially useful for webpages that need to be accessed multiple times, such as a page of fast changing financial data. 

Note that this technique will not work with many web pages. Unfortunately, we have to use a trial-and-error approach to find suitable web pages. Once we find a web page that works, however, we can then save quite a bit of time.

Procedure:
Using a web browser, go to: https://www.cnbc.com/currencies/   

Another good website for currency exchange rates is: https://x-rates.com/
[bookmark: _GoBack]At this site, click on the Rates Table link.
[image: ]
Copy the address of the web page.
In Excel 2016, create a New Blank Workbook
Click the Data tab.
In the Get & Transform group on the left, click: From Web
[image: ]
In the From Web dialog box, Paste the address of the web page and click OK.
[image: ]
In the “Access Web content” dialog, confirm that you will be making an Anonymous connection, and click Connect. (If you are accessing a website that requires a password, click the Basic tab on the left and enter the required user name and password.)
[image: ]
In the Navigator dialog box, click each table on the left until you find the one containing the data you desire. Then click Load.
[image: ]
A new sheet will appear with a formatted table containing the data from the web page.
On the right, a Queries & Connections pane will appear with the new query. To close the Queries & Connections pane, click the X in the upper right corner.
[image: ]
Now you can format the currency price table on the left as you like. For example, hide (but do not delete) any unwanted columns. If desired, format any columns with Conditional Formatting to highlight major changes. Right-click the worksheet tab and rename the sheet as: Currency Prices
How to Use the New Query
In the future, you can get the latest currency prices in just a few mouse clicks: Click the Data tab and then Queries & Connections. Then right-click the query on the right and choose Refresh. The table of prices will be updated automatically.


[bookmark: _Toc520278730]Get Data from a Stepped Layout Table
A stepped table such as the one below may be easy to read, but it is not a standard dataset format. If data is not in a standard dataset format, Excel will have a hard time analyzing the data with Pivot Tables and other techniques. 
[image: ]
Fortunately, the Get & Transform tool can easily transform such a table into a useful dataset.
Procedure:
Move the file Stepped-Data-Table.xlsx into an appropriate folder, but don’t open it.
This file is in a zipped folder. If you have not already downloaded it, click:
      Get-and-Transform-Data-Files.zip

In Excel 2016, create a New Blank Workbook
Click the Data tab.
Find the Get & Transform group on the left
Click: Get Data > From File > From Workbook
[image: ]
In the Import Data dialog box, browse to the folder containing the file Stepped-Data-Table.xlsx and double-click the file.
In the Navigator dialog box, click the table icon (Stepped) on the left if it is not already selected.
At the bottom of the Navigator dialog box, click: Edit
[image: ]
The Power Query Editor will appear showing the table.
Repeat the Branch Data on Each Row
In standard dataset format, the Branch data should appear on all rows. Get & Transform can easily copy this data to all rows where the Branch data is now blank or “null”.
Click the Branch column header to select the column (if not already selected).
Click the Transform tab and then click the Fill button (3) and choose Down:
 [image: ]
Now each cell in the Branch column will be automatically copied to the null cells below it.
Copy the Salesperson Data to All Rows
Click the Salesperson column header and repeat the above Fill procedure.
Remove the Totals Rows
Now we can remove the Totals rows, which each have a null in the Item column.
Click the Item column header to select it.
Click the Filter button (1) in the Item column header, then click Remove Empty  
[image: ]
Give the Query a Suitable Name
Locate the “Query Settings” task pane on the right.
Click the Name box and rename the query as: Get Stepped Table
Save and Run the Query
In the upper left, click Home tab, and then the top part of the button Close & Load.
[image: ]
A new worksheet will appear as a formatted Excel Table showing the imported data:
[image: ]
Rename the worksheet as: UnStepped Data

Using the Query with New Data: 
Once you set up this Get Data Query, you can use it on updated versions of the underlying stepped data file. For example:

Open the file: Stepped-Data-Table.xlsx
Insert a row above row 20
In the new row 20, set the Item as Doughnuts and the Sales as 99
The new data should look like the data below in blue. The total rows are now incorrect, but these will be filtered out during the import process.
[image: ]
Save the file
Return to the UnStepped Data workbook file
Right-click the green query at the right and choose Refresh
Note how the data change


[bookmark: _Toc520278731]Get Data from a Multi-Column Table
A multi-column table such as a Pivot Table provides a great amount of information in a small space, but it is not in a standard dataset format. And, as before, if data is not in a standard dataset format, it will be difficult to analyze it using Pivot Tables and other tools. 
[image: ]
Fortunately, the Get & Transform tool can easily transform such a table into a useful dataset. Fittingly, the specific tool we will be using is called UnPivot. Note that in this project the Get & Transform feature can handle text files such as .csv as easily as it does Excel workbook files.
Procedure:
Move the file Multi-Column-Table.csv into an appropriate folder, but don’t open it.
This file is located in a zipped folder. If you have not already downloaded it, click:
      Get-and-Transform-Data-Files.zip

In Excel 2016, create a New Blank Workbook
Click the Data tab
Find the Get & Transform group on the left
Click: From Text/CSV
In the Import Data dialog box, browse to the folder containing the file and double-click the file.
In the dialog box, click Edit
[image: ]
Select the Primary Column
The Power Query Editor window appears
Click the Salesperson column header to select the column, if not already selected.
“Unpivot” the Other Columns
Click the Transform tab.  
Click the arrow to the right of the Unpivot button and choose Unpivot Other Columns
[image: ]
Right-click the Attribute column header and rename it as Item
Right-click the Value column header and rename it as Amount
Click the Filter button for the Item column (1), clear the checkbox for Grand Total 
Click: OK
[image: ]
Click the Filter button for the Salesperson column, clear the checkbox for Grand Total
Click: OK
Close and Run the Query
Click the Home tab
Click the top part of the Close & Load button
A new worksheet will appear with as a formatted Excel Table showing the imported data:
[image: ]
Rename the new worksheet tab as: Multi-Column Data



[bookmark: _Toc520278732]Get and Combine Data
Every week or month, you may have to import a data file and add it to a master table. Instead of copying and pasting each time, you can now get the job done with just a few mouse clicks. How? By using the Combine feature of the Get & Transform tool in Excel. The really great thing here is that you don’t have to name the files or even select them; you simply copy the files into a particular folder. Once you set up the query, you can import data into Excel just by refreshing the query.

[image: ][image: ]In this exercise, we will combine two Excel spreadsheets: Atlanta.xlsx and Boston.xlsx. Note that in addition to appending the files, we will also include the filenames as a field or label in the resulting data table, thus identifying the city where each transaction took place.Atlanta.xlsx
Boston.xlsx

Note that all the data files have to have the same layout, i.e., the same column headers and the same type of data in the respective columns. Also, the files should use the new “.xlsx” or “.xlsm” formats. The older “.xls” format could cause problems.

Procedure:
Create a folder called Files to Import (or similar) and copy the Atlanta.xlsx and Boston.xlsx files into it.
Open Excel 2016 and create a New Blank Workbook
Click Data > Get Data > From File > From Folder
[image: ]
Browse to the folder containing the data files
[image: ]

Click: Combine > Combine & Edit
[image: ]
Select the table Sheet1
[image: ]
Click: OK
The  Power Query Editor window will appear
Add the Filename as a Value in Each Row
In this project, the name of each file in important and must be added to each row from that file. First, we will correctly label the first column and clean up the data there. Note: if the filenames are not important, simply right-click the Source.Name column header and choose Remove.
Right-click the column header for the Source.Name column and choose Rename
[image: ]
Enter: City
Clean the Data in the City Column
We need to remove the filename extension (“.xlsx”) by filtering out the period and everything following it.
With the City column selected, click Transform > Extract > Text Before Delimiter 
	[image: ]
Type a period and click: OK
[image: ]
Move the City Column to an Appropriate Location
With the left mouse button, drag the City column header and position it between the columns Item and Salesperson
[image: ]
On the right side of the Query Editor, give the query a suitable name, such as, Combined Files:
[image: ]
Note that if you make a mistake, you can undo any step by deleting it from the list on the right:
[image: ]
Click: Home > Close & Load
[image: ]
A new worksheet will appear in your current workbook with the result of the query:
[image: ]
Rename the worksheet tab as desired

To update the query:
Copy the Cleveland.xlsx file into the Files to Import folder
In Excel, if needed, display the Queries by clicking: Data > Queries & Connections
Right-click the query Combined Files and choose: Refresh

For More Information:
For more details on this technique, including some very powerful additional features, check out the following video:

	https://www.youtube.com/watch?v=yEmQHGv6KXs 



[bookmark: _Toc520278733]Get and Merge Data
[image: ]In this exercise, we have two workbooks: a table of sales, and a table of margins. With the Get & Transform feature, we are going to merge the two workbooks together in order to calculate the net profit for each salesperson.
[image: ]

Procedure:
Import the Data Files by Creating Queries
1. In Excel, create a New Blank Workbook
2. In the Data tab, click Get Data > From File > From Workbook 
3. Import the file Sales.xlsx 
4. In the Navigator dialog box, click Sheet1 and click: Edit
5. In the Power Query Editor, click the Name box and type: Sales Without Margins
6. Click the bottom half of the Close & Load button and choose: Close and Load to:
[image: ]
7. In the Import Data dialog box, click the option button: Only Create Connection
8. Click OK
[image: ]
9. Repeat the above with the Margins.xlsx file, naming the query: Margins Lookup Table
Join the Queries
In the Data tab, click: Get Data > Combine Queries > Merge
[image: ]
In the Merge dialog box, click the first list box (1) and choose Sales Without Margins
In the preview box (2), click the Item column
Click the second list box (3) and choose Margins Lookup Table
In the second preview box (4), click the Item column
In the Join Kind list box (5), choose Left Outer (all from first, matching from second)  
Click: OK
[image: ]
Adjust the Lookup Column Format
1. In the Power Query Editor, click the expand button (1) for the Margins Lookup Table column
1. Clear the checkbox for Item
1. Clear the checkbox for Use original column name as prefix
1. Click OK
[image: ]
Add a Calculated Column
1. In the Power Query Editor, click the Add Column tab
Click: Custom Column
In the Custom Column dialog box, click the “New column name” box and type Margin $
In the “Custom column formula” box, type the formula: 
   =Number.Round([Sales]*[Margin],2)
Note that formula is case sensitive and uses a new Power Query function: Number.Round
[image: ]
Close and Run the New Query
1. In the Power Query Editor, click the Home tab
Click the top half of the button Close & Load
A new table will appear with the merged data.
[image: C:\Users\RICHMA~1\AppData\Local\Temp\SNAGHTML55dccdf.PNG]
Rename the new worksheet as: Merged Data
Save the workbook as Merged Data
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