How to Set up a Budget — Advanced Excel

How to Set up a Budget — Advanced Excel
A budget is probably the most important spreadsheet you can create. A good budget will keep
you focused on your ultimate financial goal and help you avoid pitfalls like that adorable
timeshare on Aruba. Budgets are surprisingly popular among rich people. You would think that
wealthy people have so much money that they do not need a budget.
But according to the book The Millionaire Next Door by Thomas
J. Stanley and William D. Danko, most wealthy people in fact do
have budgets, which may be part of the reason why they are
rich in the first place.
In this project, we are going to set up not only a budget, but also
a ledger to keep track of expenses and a budget report to show
how our actual expenditures compared with our budget. This project
presents an ideal case for taking advantage of some of the more advanced features of Excel. If
you do this project, not only will you learn how to use some amazingly powerful features of
Excel, you will also create an extremely useful spreadsheet, indeed one that may save you a lot
of money in the future.
This project is divided into four parts: The Budget itself, a Ledger for keeping track of expenses,
a Pivot Table for analyzing expenses, and a Budget Report for comparing actual expenses with
the budgeted amounts. Although the parts build on each other, they can be done independently.
You can skip a part if you want. Some advanced users may skip the first part, as it reviews a
number of the more basic skills in Excel. Of course, if you are in a hurry, you can skip all the
parts and simply use the budget file as a budget template. Just use the worksheets with the suffix
“2”.
This project is designed for the latest version of Excel 2016 (Windows) under the Office 365
rental program as of July 2017. Most if not all the features used in this project are available,
although the exact directions for their use may vary, especially on the Macintosh versions.
I hope you enjoy, learn from, and/or take advantage of the material here. If you spot a mistake or
notice a possible improvement, please let me know.
— Rich Malloy
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A. Set up a Budget
In this first part of our Advanced Budget Project, we are going to set up the actual budget. A
budget is simply a plan, in this case a plan for getting and spending money. Like all plans,
budgets do not fare extremely well when they come up against reality. But that may not entirely
be the point. President and five-star general Dwight D. Eisenhower once said, “In preparing for
battle I have always found that plans are useless, but planning is indispensable."
Most budgets usually entail a whole year. To save space we are setting up a simple budget that
covers only six months and a just handful of expense categories. For your own personal budgets,
you can easily add additional months and categories to match your own needs.

Skills Used:
•
•
•
•

AutoFill
AutoSum
Apply Cell Styles
Modify Cell Styles

•
•
•

Format as Table
Absolute Cell References
Goal Seek

Procedure:
Prepare the Budget File:
• Open the file: advbudget.xlsx
• Go to the Budget sheet.
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As you can see, much of the budget is already done. I’ve included some sample categories and
data, and you can easily substitute this material with your own categories and data.
To complete our budget, we will review some basic skills in Excel. One of the skills we will use
is the formatted Excel table. Not only will this make our data look really nice, but it will also
provide some additional depth will be very handy.
If you would prefer to skip these steps, go to Part B: The Ledger.
Add the Additional Month Names:
• Click the cell containing Jan.
• Locate the Fill handle at the lower right corner of the active cell.
• Drag the Fill handle to the right, across the five adjacent cells to fill in the subsequent

months.

•

Those five cells will be filled with the months Feb through Jun.

Calculate the Totals:

•
•
•

Select all of the cells in the Total column by clicking in the middle of cell H11 and
dragging down to cell H16.
Click the AutoSum button on the right side of the Home tab.
Sums will appear in the Total column.

Format Using Cell Styles:
• Click cell A1.
• In the Home tab, display the cell styles gallery by clicking the More button (
right of the Styles group. (On smaller screens, click the button Cell Styles.)
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OR
•
•
•
•

In the Sale Styles gallery, click Title.
Click the cell containing the label Expenses.
In the Sale Styles gallery, click Heading 1.
Right-click the Heading 1 Cell Style and change the format to Italic.

Set the Expense Budget Range as a Formatted Table:

A formatted Excel Table not only looks good, but it also has special powers that make certain
tasks easier. Creating a Table is often very easy: Just click any cell in the table range. In this
case, however, we have two rows of labels at the top. To keep Excel from being confused by this
slightly complex structure, we will manually select the cells for the table.
•
•
•
•
•
•

Click cell A10 and drag to select the range A10:H16.
Click: Home > Format as Table.
o A gallery of table formats will appear.
Choose a desirable format in the Medium group.
To remove the unnecessary filter buttons in the column header cells, click the Data tab
and then click the Filter button to toggle the filters off.
Click the Table Tools Design tab, which appears whenever you select a cell in a
formatted table.
On the left side of the Table Tools Design tab, change the Table Name to ExpBudget.

Add a Total Row to a Formatted Table

One of the several nice features of an Excel formatted table is the ability to create a total row.
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Click any cell in the expense budget table.
Click the tab for Table Tools Design.
Click the checkbox for Total Row.
A new row will appear at the bottom of the budget with the label Total.
Click the Total cell in the Jan column.
A list button will appear at the right.
Click the list button and choose Sum.
A total will appear in the Jan column.
Click the Fill button in the Jan Total cell and drag it to the right to fill the other cells in
the Total row.
Of course, now that we have our total expenses as well as our total income, we must
calculate our Net Income.
Click the Jan cell in the Net Income row.
Type: =
Click the cell containing the total income for Jan.
Type: Click this cell containing the total expenses for Jan.
Press the Enter key.
Use the Fill handle to copy this formula to the other cells in this row.
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•

Note that the formula we created referred to the names of the cells, rather than explicit
references, such as B7. This is another benefit of using formatted Excel Tables.

Add a Column to Calculate % of Total.

Although not usually necessary for a budget, it could be useful to see how the total of each
category compares with the total of all expenses.
•
•
•
•
•
•
•
•

•
•

Click cell I10 (to the right of the cell that reads Total).
Enter: % of Total
o Note that a new formatted column appears. (Yet another benefit of, well, you
know what.)
Click cell I11.
Type: =
Click cell H11.
Type: /
Click cell H17
Press Enter.
o Note again that Excel used names for the selected cells in the formula.
o Also note that the formula is automatically copied to the rest of the cells in the
column — and we didn’t have to use an absolute reference in the formula.
Because Excel used named cells, and absolute reference was unnecessary.
Select and format all the cells as percentages using the % button in the Home tab.
Copy the Total in cell H17 to cell I17.

Insert a Row for Savings.

We are going to add a new category for Savings for two reasons: First, it is always good to set
aside some money for a rainy day. And second, watch how a formatted Excel Table handles
insertions and absolute cell references.
•
•
•
•
•
•

Right-click the row label 16 and choose Insert.
Note that a new row appears and the banding adjusts automatically.
In cell A16 enter the label: Savings
Create a formula in cell B16 to calculate the savings amount based on the percentage in
cell A23 and the Total Income in cell B7:
o = $A$23 * B7
Copy the formula to the cells for the other months (excluding columns H and I).
If necessary, copy the formulas in cells H15 and I15 to the cells in row 16.

Use Goal Seek to Fine-Tune the Savings Amount:

We have arbitrarily set our savings target as 5% of our total income. What if we wanted to
change that slightly so that our target savings rate would be 5% of total expenses? That would be
a difficult calculation, requiring several trials and errors. But we can easily make this calculation
using Excel’s powerful Goal Seek tool.
•
•
•
•
•
•

Select cell I16.
Click the Data tab.
Click the button: What If Analysis
Click: Goal Seek…
Click the box for To value:
Type: 5%
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•
•

Click the box labeled: By changing cell:
Type A23

•
•

Click OK
Note that the cell A23 changes to a value slightly lower than 5%.

That’s it! Our budget is finished. The only thing left is to adjust all the number formats as
desired. Speaking of numbers, be patient with me while we use these sample numbers and
expense categories. When we are all finished, you can start again with your actual expense
categories and amounts, and then you’ll be on the way to Millionaire Land, or at least to some
rational monetary management.
After you are finished, take a close look at your budget and compare it with the sheet Budget 2.
In the next part of the project, we will create a Ledger to keep track of our actual expenses.

B. The Ledger
Having a budget is a great first step. Now we must follow the budget, or at least try to. This
means categorizing and adding up perhaps hundreds of expenses throughout the year. As we
shall see later, Excel has special functions that will make categorizing and adding a breeze. But
first we have to record all the expense data into a table we call the Ledger.
A Ledger is simply a record of all income and expenses. In this project, we will create a
ledger for expenses. Later the fun will begin when we conjure up some special magic in Excel to
see if we are on — or off — budget.

Skills Used:
•
•

Format as Table
Data Validation with a List

•
•

The SUBTOTAL function
Slicers

Procedure:
Open the Spreadsheet:

•
•

If it is not open already, open the file: advbudget.xlsx
Go to the Ledger sheet.

Set the Ledger Range as a Formatted Table.

•
•

Click any cell in the ledger range of cells.
Click: Home > Format as Table.
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•
•
•

o A gallery of table formats will appear. Again, note that on some large displays, one
row of the gallery will already be displayed. You can then display the whole gallery
by clicking the More button at the bottom right of the table format buttons.
Choose a desired format in the Medium group.
Click the Table Tools Design tab.
On the left side of the Table Tools Design tab, change the Table Name to ExpLedger.

Format the Dates and Dollar Amounts

•
•
•
•
•
•
•
•
•

Select all the date cells in column A.
o Shortcut: Click the first cell. Then press Ctrl + Shift + ▼ (the down arrow key).
Right-click one of the cells and choose Format Cells…
In the Format Cells dialog box, be sure the Number tab is selected.
Choose the Date category and the format: 3/14.
Select all the number cells in column D.
Right-click one of the cells and choose Format Cells…
In the Format Cells dialog box, be sure the Number tab is selected.
Choose the Number category.
Set the format with 2 decimal places and use the 1000 separator.

Add a Total Row.
• Click the Table Tools Design tab.
• Click the check box for Total Row.

•

A cell with a Sum formula should appear at the bottom of the Amount column.

Filter the Table by Category and Date.

•
•
•

Unlike the case with our Budget, the filter buttons in our Ledger actually do serve a
purpose.
Click the filter button for Category.
Clear some of the Category check boxes and click OK.
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•
•
•

Note how the Total changes.
Click the filter button for Category again.
Click the check box for Select All and click OK.

Add New Entries at the Bottom of the Table.

The Total row is handy, but it makes it difficult to add new rows to the bottom of the table. As
we spend more money throughout the year, we will unfortunately be adding quite a few more
rows to our table. We certainly want to make that process as easy as possible, which means we
must remove the Total row. But, we can replace it with something better.
•
•
•
•
•

Click the Table Tools Design tab.
Clear the check box for Total Row.
Click the empty cell under the last date in the table.
Type the date 4/15 and press Tab.
Note that a new formatted row appears at the bottom of the table.

Use Data Validation to Make it Easy to Add Categories:

Now it is easy to add an expense to your table, but if you accidentally misspell a category, it
could cause problems later in our Budget Report. To keep that from happening—and to make it
much easier to enter categories—we are going to use a secret Excel tool called Data Validation.
With this tool, you can enter a category simply by choosing it from a drop-down list.
•
•

Select all the cells in the Category column (excluding the column header at the top).
o Shortcut: Click the first cell. Then press Ctrl + Shift + ▼ (the down arrow key).
In the Data tab, click the Data Validation button.
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•
•
•

In the Allow box, click the list arrow and choose List.
Click in the Source: box, and then click the Budget 2 sheet tab.
Select the expense category names in column A (excluding the column header at the top
and the “Total” at the bottom).

•
•
•
•

Click OK.
Click the Category cell in the new row you added.
A drop-down list should appear.
Click any of the options in the list.

Use a Dynamic List with Data Validation:

The list we just created with Data Validation is fantastic, but it is static. It simply refers to
explicit cell references, A11:A17. If we later add a new category at the bottom of our budget,
that new category might be outside this cell range, and then might not automatically appear in
our data validation list. But, don’t worry. One of the great things about formatted Excel tables is
that they are dynamic. We can make use of this by creating a dynamic named range, which we
can then use in our data validation list.
•
•
•

Click the Budget 2 sheet tab.
In column A select the category names, excluding the column header at the top in the
Total label at the bottom.
In the Name Box at the upper left, type Categories
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•

•
•
•

The name Categories now refers to the dynamic range in the Expense Budget table. As
new categories are added to the budget, they will automatically be included in the named
range Categories.
Click the tab for the Ledger sheet.
Select all the categories in the Category column, excluding the column header.
In the Data tab, click the Data Validation button.
In the Allow box, click the list arrow and choose List.
Click in the Source: box, type = and then press the F3 key.
A list of names will appear.

•
•

Click Categories.
Click OK.

•
•
•

Now when you click in any of the Category cells, a list arrow will appear at the right. If you click
the arrow, you can choose from all the allowable categories.
Add SUM and SUBTOTAL Formulas above the Table.

Instead of putting a total row at the bottom of our table, it is sometimes better to put the total at
the top of our table, where it is easier to see.
•

Insert three blank rows at the top of the table.
o Right-click the row label 3 and choose Insert.
o Press the function key F4.
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•
•
•
•

•
•

o Press the F4 key again to repeat the action once more.
In cell C4 enter a label: Grand Total
in cell D4 enter a formula that will sum up all amounts.
o Formula: = SUM(ExpLedger[Amount])
o Note that as you type the names, Excel will automatically complete the names.
In cell C3 enter a label: Filtered Total.
In cell D3 enter a formula that will add up the displayed amounts.
o Formula: = SUBTOTAL(109, ExpenseLedger[Amount])
o The code 109 tells Excel to do a conditional SUM, adding up only those numbers
that are displayed by any filters that happen to be in place. Click here to see all the
possible codes.
Use the Format Painter button to copy the format from cell D4 to D3.
Use the filter buttons to filter the table by Category and notice how the totals change.

Add a Column at the Right to Show the Month Name.

To see if we are “on budget” we will need to filter our data not just by Category but also by
month. The easiest way to do that is to add another column to our ledger table that will display
the month of each expenditure.
•
•
•
•
•
•
•

Click the cell to the right of the column header Amount.
Type: Month
Click the cell below the label Month.
Type: = text(
Click the cell containing the date in that same row.
Enter: , "mmm")
The code mmm instructs Excel TEXT function to display the three-letter abbreviation of
each month.

Add Slicers to Filter the Table.

Filter buttons are nice, but Microsoft has recently provided an amazing feature that makes
filtering data immeasurably easier: Slicers.
•
•
•
•

Right-click the row label 3.
Choose: Insert
Use the F4 key to repeat the above 5 times.
Add a Slicer for Category and Month.
o Click any cell in the Expense Ledger table.
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o In the Table Tools Design tab, click Insert Slicer
o Click the checkboxes for Category and Month.

•
•
•
•
•

o Two rectangles will appear on the spreadsheet.
Use the sizing handles of the Month Slicer to adjust the size so that it is only large
enough to display the three buttons in the names of the months.
Click the Category Slicer.
Click the Slicer Tools Options tab.
Click the Columns box and type 3
Adjust the width of the buttons to 0.9 inch.

•

Use the sizing handles of the Category Slicer to remove any wasted space. Drag the
slicers to the empty space above the table.

•
•

Click one of the Category buttons and one of the Month buttons.
Note how the display and the total changes. Use the Control and Shift keys to display
more than one Category or Month.
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That’s it! Our Ledger is done. It should look pretty much like the ledger on the sheet Ledger 2.
Now comes the hard part: recording all of our expenditures. The job will be a lot easier knowing
that we are taking advantage of some really powerful Excel features!
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C. Use a PivotTable to Summarize Data
In the first two parts of our Advanced Budget Project for Excel 2016 in Windows, we set up the
Budget itself and then created a Ledger table to keep track of our expenses. In the Ledger table,
we set up filters using Excel’s Slicers so that we could see the total expenditures for each
expense category and each month. The Slicer buttons are slick, but it will be tedious to use them
to examine every single category and every month. There must be a better way.
And there is, of course. The fastest and easiest way to summarize a table is to use Excel’s
Pivot Tables. This amazing feature has somehow obtained the reputation of being difficult, but I
will let you in on a secret: Even though Pivot Tables are incredibly powerful, they are also
surprisingly easy.
In this third part of our Advanced Budget project, we will set up a Pivot Table to see how
the expenditures in our Expense Ledger are doing. In just a handful of mouse clicks, we’ll be
able to peruse a summary of total expenses for all categories and months at the same time. We’ll
also use two Excel features to give us a visual summary of our expenditures. Sparklines will
show us a basic look at how our expenditures vary month to month, while a Pivot Chart will give
us a much more detailed look.
Once you create a Pivot Table, you will be amazed at how easy it was. But don’t tell
anyone. Let everyone continue to believe that this feature is too difficult for most people. And, of
course, they will all be very impressed when you create them so quickly.

Skills Used:
•
•

Creating a Pivot Table
Formatting a Pivot Table

•
•

Using Sparklines
Creating a Pivot Chart

Procedure:
Open the Spreadsheet:

•
•

If it is not open already, open the file: advbudget.xlsx
Go to the Ledger 2 sheet.

Insert a Pivot Table:

Okay, here we go. Watch how easy it is to create a Pivot Table:
•
•
•
•
•
•

Click somewhere in the Ledger table.
Click Insert > Pivot Table.
Click the OK button to set the Pivot Table on a new sheet.
A new sheet will appear, with a strange design on the left hand and a list of column
headers (or fields) on the right. Below the fields, are four boxes. All we need to do now is
to move the right field into the right box.
Drag Category into the Rows box.
Drag Amount into the Values box.
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•
•

There you have it! You’ve create a Pivot Table. Now let’s make it even better.
Drag Month into the Columns box.

•

Let’s stop and admire what we have done here: With a few mouse clicks we have sliced
and diced our Ledger data by two different criteria. Amazing.

Format the PivotTable:

We need to make some cosmetic improvements:
•
•
•
•
•
•
•
•
•
•

Click any of the number cells in the Pivot Table.
Click the PivotTable Tools Analyze tab.
On the left of the ribbon, click Field Settings.
Click the button Number Format.
Select a Number format, with 0 Decimal places and a 1000 Separator.
Click OK twice.
Click the PivotTable Tools Design tab.
Click: Report Layout.
Click: Show in Outline Format.
The PivotTable now shows titles for the table axes.
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Update the PivotTable:

A Pivot Table is great, but does it immediately respond to new data?
•
•
•
•
•
•
•

Rename the sheet tab for your Pivot Table as, well, Pivot Table
Click the tab for Ledger 2 (not Ledger).
Add a new expense entry to the bottom of the Expense Ledger.
Click the tab for the Pivot Table.
Note that the Pivot Table does not automatically recalculate.
Right-click any cell in the Pivot Table and choose Refresh.
The table will now update itself.

Insert Sparklines to Analyze Data:

Sparklines are tiny graphs that reside inside individual cells. They can give you a quick visual
cue of trends in your data.
•
•
•
•
•
•
•
•
•

Click cell F4.
Enter: Trend
With Format Painter, copy the format from E3:E4 to F3.
Click cell F5.
In the Sparklines group on the Insert tab, click the button: Column
In the Data Range box that appears, type B5:D5
Click OK.
Copy cell F5 down to the cells below it.
With Format Painter, copy the format of cell E12 to F12.

•

With the Sparklines, you can quickly see that there were big jumps in March for the
Groceries and Misc. categories.

Insert a Pivot Chart (Stacked Column) to Analyze the Data More Precisely:

One of the advantages of a Pivot Table is that you can quickly and easily create a chart. Yes, it is
unlikely that you will ever need to create a chart of your expenses, but if this were a table of
business expenses, it might prove useful.
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•
•
•
•
•
•
•
•
•
•
•

When we create a chart, the Sparklines will be unnecessary, and they might get in the
way. So, let’s remove them by deleting column F.
Click any of the cells in the Pivot Table.
Click the PivotTable Tools Analyze tab.
On the right of the ribbon, click PivotChart.
Choose a Stacked Column Chart.
In our chart, the Months are listed in the Legend. But chronological data is usually placed
on the horizontal axes. Let’s fix it.
Drag the Category field from the Legend (Series) box to the Axis (Categories) box.
Drag the Month field from the Axis (Categories) box to the Legend (Series) box.
You have just pivoted the table (and the chart) with two mouse clicks! That’s why they
call it a Pivot Table. Now the chart shows the data chronologically by month.
Move the chart below the Pivot Table and resize it to fit the space.
In the PivotChart Tools Analyze tab, click the button on the right: Field Buttons
o This removes the headings above the two axes and the legend.

Your Pivot Table is finished. If you’ve done everything right, it should look like the table in the
worksheet PivotTable 2. The table provides an excellent summary of our expenses for the last
three months. With the pivot table, the Sparklines, and/or the pivot chart you can quickly analyze
the category expenses month to month or with the other expenses.
The next step, obviously, is to compare these actual expenses with our budget. Unfortunately, the
Pivot Table now presents us with two problems.
First, unlike Excel formulas, Excel charts, and pretty much everything else in Excel, Pivot Tables
do not automatically recalculate when the underlying data change. You can verify this yourself:
Just add a new expenditure to the bottom of the Expense Ledger and then look back at the Pivot
Table. Incredibly, there is no change. Pivot Tables keep a static version of the data, which is a
fancy way of saying that they are taking a nap. To wake the Pivot Table up, as it were, you need
to Refresh it. Just right-click any cell in the table and choose Refresh. That is not too difficult,
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but the likelihood of forgetting to Refresh is too real, which could cause you to miss sudden
pattern changes in your expenditures.
The second problem is that the structure of the Pivot Table is too rigid to be used in our Budget
Report. To compare actual expenditures with our budgeted amounts, we want to be able to
intersperse our actual columns with our budget columns. So, let’s try it: Insert a column in the
Pivot Table. Excel won’t let you. But Excel does provide us with an excellent alternative, which
we will explore in the next part of our Advanced Budget project.
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D. Create a Budget Report
Now we are at the last part of our four-part Advanced Budget Project. This is the crucial part
where we find out how we are doing relative to our budget. In the first three parts, we created the
Budget itself, a Ledger to keep track of our expenditures, and a Pivot Table to summarize our
actual expenditures.
In this part, we will set up the all-important Budget Report, that is, a comparison of budgeted
versus actual expenses. After going through the trouble of recording all of our expenses, this
Budget Report will tell us if we are on budget or not. The pivot table we created in the last part
already gives us a good summary of our expenditures. Ideally, we would like to insert some
columns into the pivot table where we could display the budget estimates right next the actual
expenses. Unfortunately, pivot tables are too inflexible for this. We could copy the pivot table
values into a second table that would be more flexible, but this starts getting complicated real
fast. Fortunately, there is much more direct way.
If we want to compare our actual expenditures with our budget, we need to summarize our
actual amounts, and the best way to do that is with an Excel function called SUMIFS. You may
already be familiar with the SUMIF function, which is handy for adding up numbers that meet a
certain condition. And yes, if all we wanted was to find the total expenses in each category and
did not care about the month, the simple SUMIF function would be fine.
But for our summary, we want to add up the expenses based on two conditions, Category and
Month. For example, we want to see the total Groceries expenses for each individual month: Jan,
Feb, and Mar. The SUMIFS function is perfect for this. Unlike the simple SUMIF function, it
can add up items according to any number of different conditions. And unlike the pivot table, the
SUMIFS function updates itself automatically. Think of that last “S” in SUMIFS as standing for
“Super”.
Because of space considerations, we will do a Budget Report only for the first quarter of the
year. The procedures for the other quarters are exactly the same.

Skills Used:
•
•

The SUMIFS function
Linking cells to other sheets using a
formatted table

•
•

Conditional Formatting
Cell Styles

Procedure:
Open the Spreadsheet:

•
•

If it is not open already, open the file: advbudget.xlsx
Go to the 1Q Report sheet.

Set up the Report Worksheet.
All we have in the 1Q Report are a few labels in rows 9 and 10. The first thing we need to do is

to add the budget categories to column A. Instead of copying and pasting the categories from the
Budget sheet, we’ll use a formula to link the cells to the Budget sheet. And, because we used a
formatted Excel table on our Budget sheet, we can use meaningful range names in our formulas
rather than cryptic explicit references such as “'Budget 2'!A11”. Note, however, that for these
formulas to work, the items in the budget report sheet have to be on the same rows as they are in
the Budget sheet. (That explains why the mystery of why there are so many empty rows above
our budget report.)
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•
•
•

Click cell A11.
Type: =ex
In the drop-down list, double-click ExpBudget2

•
•
•

Type: [c
In the drop-down list, Category should be selected.
Press: Tab
Note that you can select an item in a drop-down list either by double-clicking it, or
single-clicking it and pressing the Tab key.
Type: ]
o The formula should be: =ExpBudget2[Category]
Press: Enter
Copy the contents of A11 to cells A12 through A17.

•
•
•

Note that the formula in each of the cells A11:A17 is the same. Excel determines which
label to put in a cell by examining the formula’s row number and finding the same row in
the Budget sheet..
Use the SUMIFS Function to Add up Expenses for Each Category.

Now we need to get a summary of our actual expenses from our Ledger sheet. In the previous
section of this project, we used a Pivot Table to do this. The Pivot Table was quick to set up, but
not flexible enough for our budget report. So, instead of a Pivot Table we will use the SUMIFS
function, a super powerful relative of the SUMIF function.
Let’s ease into the SUMIFS function. This powerful function can add up amounts based on
several criteria. But in our first test run with it, we will use only one criterion.
•
•
•

Click cell B11.
Type: =sum
In the list of functions that appears, double-click SUMIFS.
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•
•
•
•
•
•
•
•
•
•

Click the Insert Function button (fx).
Click the box Sum_range.
Click the tab Ledger 2.
Select all the cells in the Amount column, excluding the column header.
o Shortcut: Click the first cell. Then press Ctrl + Shift + ▼ (the down arrow key).
Click the box Criteria_range1.
Click the tab Ledger 2.
Select all the cells in the Category column, again excluding the column header.
Click the box Criteria1.
In the Report sheet, click cell A11.
Press the function key F4 three times to insert a $ in front of the A (as in $A6).

•

Click OK.
o The formula should be:

•

Click and drag down the fill handle of cell B11 to fill the other cells in the column down
to B17.

=SUMIFS(ExpLedger2[Amount], ExpLedger2[Category], $A11)

The Jan column now shows total actual expenses for each category — and for all
months.
Modify the SUMIFS Function to Add up Expenses for Each Category and Each Month:

As you can see, the SUMIFS function in the Jan column does a good job of adding up the
expenses for all the months. Now let’s adjust the function so that it adds up the expenses only for
Jan.
•
•
•
•
•

Click cell B11.
Click the Insert Function button (fx).
Click the box Criteria1.
A new optional box will appear.
Click the box Criteria_range2.
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•
•
•
•
•

•

•
•
•

Click the tab Ledger 2.
Select all the cells in the Month column, excluding the column header.
o Shortcut: Click the first cell. Then press Ctrl + Shift + ▼ (the down arrow key).
Click the box Criteria1.
In the 1Q Report sheet, click cell B10.
Press the function key F4 twice to insert a $ in front of the 4 (as in B$10).

Click OK
o The formula should be:
=SUMIFS(ExpLedger2[Amount], ExpLedger2[Category], $A11,
ExpLedger2[Month], B$9)
Click and drag down the fill handle of cell B11 to fill the other cells in the column.
The Jan column now shows the summary of expenses for January.
Copy the formulas in the Jan column and Paste them into the Feb and Mar columns.
o Important Note: Do NOT use the Fill button to copy the formulas to the other
months. If you do, the cell references in the Ledger 2 formatted table will shift to

the right and will point to the wrong columns. Instead, if you copy and paste the
formulas, the cell references will act as absolute references and will continue to
point to the correct columns.

Note that in the dummy data in this project I used slightly different amounts. See the Rent
and TV categories, which would normally be constant for each month. This makes it easy
to check that the right data is going into the right cells.
Link in the Budget Amounts for Comparison with the Actual Expenses:

Just as we did with a Pivot Table in the last part of this project, we now have a summary of
expenses broken down by both Category and Month. But, with the SIMIFS function, we now
have two advantages over a Pivot Table: First, the formulas update automatically as soon as the
data in the Ledger changes. And second, we can now shift the columns so that we can easily
compare the Actual expenses with the Budget for each month.
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But first we have to bring in the budget amounts. Again, we are going to use a nice feature of
formatted tables that makes it easy to link cells in one worksheet with similar cells in another
worksheet. A while back we used this technique to import the Category labels from the Budget
table. Now we will import the numbers. And, as we shall see later, this feature will also make it
easy to modify our report so that a copy of it can be quickly modified for the second quarter (and
third and fourth as well).
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Select cells B9:D9.
To copy the cells, press: Ctrl + C
Select cell E9
Paste the cells by pressing: Ctrl + V
Click cell E10.
Type: Budget
To enter the label without shifting to another cell, press Ctrl + Enter
Copy cell E10.
Select cells D10:E11.
Paste the cells by pressing: Ctrl + V
Click cell E11.
Type: =ex
In the drop-down list, double-click ExpBudget2
Type: [ and then j
In the drop-down list, Jan should be selected.
Press: Tab
Type: ]
o The formula should be: =ExpBudget2[Jan]
To copy the formula to the other cells in the column, double-click the Fill handle.
Copy cells E11:E17.
Select cells F11:G11
Paste the cells by pressing Ctrl + V.
Format the numbers by selecting cells B11:G17.
Click the Comma button.
Remove the decimal places by clicking the Decrease Decimal button twice.

Now we can move the Budget cells close to their respective Actual cells. There are two ways we
can move the cells: The first way involves holding down the Shift key.
•
•

Select cells E9:E17.
Hold down the Shift key.
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•

Move the pointer over the left border of the selected range of cells until the pointer
becomes a four-way arrow.

•

Click and hold the left mouse button and drag the pointer to the left until a thick vertical
line appears between columns B and C.

•

Release the mouse button.

The Jan Budget cells will move to the right of the Jan Actual cells. Now let’s try the second
method, which involves the right mouse button and is a little easier:
•
•
•
•

Select cells F9:F17.
Cut the cells by pressing Ctrl + X
Right-click cell D9.
Choose: Insert Cut Cells

Note that green error flags may appear, but these will soon disappear when Excel
realizes what we are trying to do. Also note how the dummy data in the Budget and
Ledger sheets makes it easy to see that the amounts are going into the proper cells for the
Rent and TV categories.
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Compare Actual and Budget Amounts with a Percentage:

With the Budget and Actual amounts right next to each other, it is easy to compare the two. To
make it even easier still, we should calculate the Actual amounts as a percent of Budget. And for
the icing on the cake, we will use Conditional Formatting to highlight any categories over
budget. But first, we’ll need to insert two more columns inside our table.
•
•
•
•
•
•
•
•
•
•
•

Right-click the column label F.
Choose: Insert.
Right-click the column label D.
Choose: Insert
Click cell D10.
Enter: % of Budget
Click cell D11.
Enter the formula: =B11/C11
Copy the formula to cells D12:D17
Select cells D11:D17.
Click the Percent Style button (%).

Highlight Over-Budget Categories with Conditional Formatting:

Now let’s use Conditional Formatting to point out the over-budget items.
•
•
•
•
•
•
•
•
•
•
•
•
•

With D11:D17 selected, click: Conditional Formatting
Choose: Highlight Cell Rules > Greater Than …
In the GREATER THAN box, type 100%
Click the arrow to the right of the format box (“Light red fill …”).
Choose: More Formats…
Choose a style of Bold.
Choose the Standard Color: Dark Red.
Select cells D10:D17.
Copy the selected cells.
Click cell G10.
Paste the cells.
Click cell J10.
Paste the cells.

Calculate Monthly Totals with the SUM Function:

Of course, it would be a good idea to use the SUM function to analyze the months as a whole:
•

Click cell A18.
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•
•
•
•
•
•
•

Enter: Total
Select cells B18:C18
Click: Home > Sum (Σ)
Copy cell: D17
Paste into cell: D18
Copy cells: B18:D18.
Paste into cells: E18:J18.

Format the Column Headings with a Cell Style:

Now let’s fix up our Budget Report so that it looks nice. First, we’ll fix up the Month labels and
format the column headings:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Select cells: B9:D9.
Click: Merge & Center
Click OK to confirm overwriting the label in C9.
Select cells: E9:G9.
Press the F4 function key to repeat the previous action.
Click OK to confirm overwriting the label in C9.
Repeat the above for cells: H9:J9.
Select cells: A9:J10.
Click: Home > Cell Styles
o On some large screens, the Cells Styles button will not appear. Instead, click the
More button ( ) at the right of the Styles group to show the Styles gallery.
Choose: Accent 1 (usually white text on a dark blue fill color).
With the cells still selected, click the Bold button.
Widen the columns as needed to show the labels completely.
Center the text in cells B10:J10.
Select cells B9:D10.
Click the arrow to the right of the Borders button.
In the drop-down menu, choose: More Borders…
In the dialog box under Style, select a medium thick solid line.
Under Color, choose a very light gray.
Under Border, click the buttons to apply the border to the right and left sides of the
selected cells.
Select cells H9:J10.
Press the F4 function key to repeat the above.
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Apply Banded Rows with Conditional Formatting

Note that we cannot simply use the Format as Table feature for this report. That feature requires
all column headings to be unique, and our report repeats the labels Actual and Budget. But, we
can use a special Condtional Formatting trick to make our table look like a formatted table. But
first, let’s fix up the Total row.
•
•
•
•
•
•
•
•
•
•
•
•
•

Select cells A18:J18.
Click: Cell Styles
o Or, click the More button in the Styles group.
Choose the style: Total
Select cells: A11:J17.
Click: Conditional Formatting
Click: New Rule
Click: Use a formula to determine which cells to format
Click in the box under Format cells where this formula is true:
Type: = mod(row(), 2)
o This uses the MOD function to select the rows with a number not easily divided
by 2; in other words, it selects every other row.
Click the Format button.
Click the Fill tab at the top.
Choose a light blue color.
Click OK twice.

Create a Summary for the First Quarter:

Now that we have analyzed our Budget vs. Actual results for three months, it would be a simple
task to have a summary for the whole quarter as well.
•
•
•
•
•
•
•
•
•

Copy cells: H9:J18.
Paste into cell K9.
Select cell K9.
Enter: First Quarter
In cell K11 enter the formula: =sum(B11, E11, H11)
Use the Fill Handle to copy the formula to the rest of the cells in the column, excluding
the Total cell.
Copy the formulas in the K column to the L column.
Copy cells J11:J18 to cell M11.
Widen column M as needed.
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A Warning About Deleting Rows

Someone may see all those empty rows above the Budget Report and decide to delete a few. If
that happens, the row numbers on the Budget Report will no longer correspond with those in the
Budget sheet, and the Budget amounts in the table will be altered. The safe way to reduce the
white space above the table is to Hide the rows rather than deleting them.
It might be a very good idea to put a notice below the Budget Report:
Warning: Deleting rows above or inside the table will disrupt
links with the Budget sheet.
Create a Budget Report for the Second Quarter:

Wait! Don’t go yet. This is much easier than it sounds.
•
•
•

First, we can make a copy of the 1Q Report and rename it 2Q Report.
Second, because our formulas refer to the month names Jan, Feb, and Mar instead of
explicit cell references, all we need to do is use the Replace tool to replace all instances
of First with Second, Jan with Apr, Feb with May, and Mar with Jun.
Don’t worry about getting 0’s in the Actual columns—we don’t yet have any expenses
for the second quarter in our Ledger yet.

Conclusion:
If you have followed parts A, B, and D of this project, you will have created a simple, yet
powerful budget spreadsheet. Part C, the Pivot Table, is optional, but could be useful for
analyzing spending habits.
Now, of course, comes the really hard part: inputting our actual expenses. Good luck, and let’s
hope this budgeting tool saves you a ton of money.
In the process of creating our budget, we’ve used several advanced Excel tools. Be sure to use
them in other projects, as they can save you quite a bit of time.
If you have questions, problems, or even improvements, please be sure to let me know. I would
be happy to hear from you.
— Rich Malloy
[End]
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